Commit 9a94f1f3 authored by phenigma's avatar phenigma

Refs #2801 - build newer openzwave on trusty/xenial

parent cebf6baa
...@@ -386,11 +386,17 @@ function Build_Replacements_ubuntu_trusty ...@@ -386,11 +386,17 @@ function Build_Replacements_ubuntu_trusty
#Build_Replacement_Package python-coherence ubuntu/Coherence-0.6.6.2 #Build_Replacement_Package python-coherence ubuntu/Coherence-0.6.6.2
# # Open ZWave library
# ver_split="-" Build_Replacement_Package zwave external/openzwave-1.3.1224
# dpkg -i ${scm_dir}/external/libopenzwave*deb
# cp ${scm_dir}/external/*zwave*.deb "${replacements_dir}"
# cp ${scm_dir}/external/*zwave*.changes "${replacements_dir}"
# Open ZWave library # Open ZWave library
ver_split="-" Build_Replacement_Package zwave external/openzwave-1.3.1224 ver_split="-" Build_Replacement_Package zwave ubuntu/open-zwave-1.5
dpkg -i ${scm_dir}/external/libopenzwave*deb dpkg -i ${scm_dir}/ubuntu/libopenzwave*deb
cp ${scm_dir}/external/*zwave*.deb "${replacements_dir}" cp ${scm_dir}/ubuntu/*zwave*.deb "${replacements_dir}"
cp ${scm_dir}/external/*zwave*.changes "${replacements_dir}" cp ${scm_dir}/ubuntu/*zwave*.changes "${replacements_dir}"
# libhupnp and libhupnp-av need to build under qt4. # libhupnp and libhupnp-av need to build under qt4.
QT_SELECT=4 Build_Replacement_Package libhupnp-core external/hupnp/hupnp QT_SELECT=4 Build_Replacement_Package libhupnp-core external/hupnp/hupnp
...@@ -474,11 +480,17 @@ function Build_Replacements_ubuntu_xenial ...@@ -474,11 +480,17 @@ function Build_Replacements_ubuntu_xenial
#Build_Replacement_Package python-coherence ubuntu/Coherence-0.6.6.2 #Build_Replacement_Package python-coherence ubuntu/Coherence-0.6.6.2
# # Open ZWave library
# ver_split="-" Build_Replacement_Package zwave external/openzwave-1.3.1224
# dpkg -i ${scm_dir}/external/libopenzwave*deb
# cp ${scm_dir}/external/*zwave*.deb "${replacements_dir}"
# cp ${scm_dir}/external/*zwave*.changes "${replacements_dir}"
# Open ZWave library # Open ZWave library
ver_split="-" Build_Replacement_Package zwave external/openzwave-1.3.1224 ver_split="-" Build_Replacement_Package zwave ubuntu/open-zwave-1.5
dpkg -i ${scm_dir}/external/libopenzwave*deb dpkg -i ${scm_dir}/ubuntu/libopenzwave*deb
cp ${scm_dir}/external/*zwave*.deb "${replacements_dir}" cp ${scm_dir}/ubuntu/*zwave*.deb "${replacements_dir}"
cp ${scm_dir}/external/*zwave*.changes "${replacements_dir}" cp ${scm_dir}/ubuntu/*zwave*.changes "${replacements_dir}"
# libhupnp and libhupnp-av need to build under qt4. # libhupnp and libhupnp-av need to build under qt4.
QT_SELECT=4 Build_Replacement_Package libhupnp-core external/hupnp/hupnp QT_SELECT=4 Build_Replacement_Package libhupnp-core external/hupnp/hupnp
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment